Eclipse nos Macs M1 (Apple Silicon / ARM)

Olá, Fluiggers!

Alguem está utilizando o Eclipse atualmente nos Macs com chip Apple M1, M2, M3?
Não consegui uma versão do Eclipse que rode perfeitamente.

Estou com dois casos principais:
Caso 1 - Ao tentar rodar as versões homologadas pela TOTVS (Luna e Neon), retorna erro “O Eclipse está corrompido”, ou “O Eclipse não pode ser aberto”.

Caso 2 - Ao tentar rodar a versão 2023-12, consigo instalar o Fluig Studio (Depois de me matar driblando um bug de Permissão de instalação de plugins do Eclipse), importar Datasets e Formulários, mas ao tentar importar um processo, a lista de diagramas não carrega.

Pessoal, depois de muitas tentativas, consegui seguindo os passos abaixo:

1 - Baixe o JDK, escolhendo a opção macOS ARM64 DMG Installer, e instale-o.
Link: https://www.oracle.com/br/java/technologies/javase/javase8u211-later-archive-downloads.html

2 - Baixe o Eclipse neste link, escolhendo a opção Eclipse IDE for Java EE Developers macOS [x86_64]
Link: https://www.eclipse.org/downloads/packages/release/neon/3

3 - Descompacte o arquivo do Eclipse, e mova para a pasta de Aplicativos.

4 - Clique com o botão direito no icone do Eclipse, e selecione Mostrar Conteúdo do Pacote. Dentro da pasta Contents, há um arquivo chamado Info.plist , abra-o com um editor de código

6 - Role até o final do arquivo, e insira o trecho de código abaixo, exatamente onde eu posicionei.
<string>-vm</string><string>/Library/Java/JavaVirtualMachines/jdk1.8.0_333.jdk/Contents/Home/bin/java</string>

7 - Substitua jdk1.8.0_333.jdk pelo nome que está a pasta do java, caso seja diferente.

8 - Abra o Eclipse, baixe e instale o Fluig Studio, e pronto!!! Eclipse funcionando perfeitamente no Macbook Air M1!!! :heart_eyes:

4 curtidas