Utilização do Plugin FLUIG no Eclipse com Macbook M1

O Fluig não é homologado oficialmente para macOS. Porém gostaria de saber se alguém está passando pelo mesmo problema que eu com os novos Macbook’s M1.

Alguém que possui a mesma máquina já conseguiu realizar importação, exportação de formulários, workflow, widgets. Qual a versão do Eclipse utilizada, foi necessário baixar algum Java ou programa a mais, alguma configuração. Afinal a versão homologada do Eclipse recomendado pela TOTVS não funciona nesta nova arquitetura.

Qual a versão do Eclipse que está usando? E - mate minha curiosidade - o M1 é tudo isso mesmo?
Pelo que li até o momento, o Rosetta2 devia resolver qualquer problema de compatibilidade.

Opa claro, sobre a curiosidade é sim, essa nova arquitetura tá demais, em relação de desempenho, o consumo de bateria reduzido, qualidade padrão apple. Mas tem esses problemas de compatibilidade com alguns aplicativos e recursos ainda. E no plugin do Fluig por exemplo estou com problemas, então se seu interesse é pra utilizar com Fluig, talvez possa vir a ter um encomodo assim como estou tendo rsrs. E como a TOTVS não da suporte pra macOS, tentei até abrir um chamado mas não me adiantou.

Estou utilizando esta versão do print abaixo.

1 curtida

Massa demais! Infelizmente não possuo um mac aqui pra tentar lhe ajudar…o @leferso tem mas acho que não é M1, né?

experimente usar o eclipse oxigen ele funciona muito bem.

Se ajudar, uso o Eclipse 2019-12, o último que testei que tem estabilidade no uso dos plugins - recentemente tentei a última versão, mas já de cara na hora de importar um processo os erros ‘sem noção’ já começaram…

Consegui fazer funcionar, deixar registrado aqui pra galera que tiver passando por esse problema com macOS também.

  1. Baixar o JRE do site da oracle (macOS x64 DMG Installer) Java Archive Downloads - Java SE 8u211 and later | Oracle Brasil
  1. Instalar o eclipse (Utilizei o Eclipse Neon 3 )

  2. Ir dentro dos arquivos do Eclipse.app → Contents/Eclipse/eclipe.ini

  3. Logo depois de --launcher.appendVmargs adicionar o trecho:

-vm
/Library/Java/JavaVirtualMachines/jdk1.8.0_301.jdk/Contents/Home/bin/java

Talvez pode dar erro pois a versão do meu JDK atualmente instalado é esta 1.8.0_301 ai caso reclame disso verifica no caminho ai listado qual a versão do seu

  1. E ta pronto o eclipse funcionando no mac m1 :wink:
3 curtidas